Animation Mentor Support Center

Animation Mentor's Required Upload Procedures - (RUP)

Summary:

This procedure is mandatory and required of all students.

In an effort to maximize our students’ and mentors’ abilities to view assignment files, we require students follow specific settings to create the video and image files uploaded to the campus. This will help ensure all the student files on the site are both consistent in quality and clarity.

Animation Mentor provides instructions on how to do this using Davinci Resolve and GIMP but you are allowed to use any video and image editing programs so long as you can reach the same file standards.

Assignment Video Standard
Framerate: 24fps (Games workshops use 30fps)
Resolution: 1280x720
FileType: MP4
Encoding: H.264

Assignment image Standard
Resolution: 1280x720
FileType: JPEG

 


 

Video File Instructions Using DaVinci

As an Animation Mentor student, you should currently have a copy of DaVinci Resolve or other video editing software. If you do not, you can find Animation Mentor’s software and hardware requirements here.

The following instructions will demonstrate how to convert a playblasted video file with audio into an MP4 file using DaVinci Resolve. The following example can also be used for videos that have multiple clips with (like a progress reel or demo reel).

1. Open DaVinci Resolve and create a new project file by selecting "New Project".
DaVinci_NewProject.jpg


2. Next hit "File - Import File - Import Media" and select the files you wish to add into your project or drag and drop the files into the Media Pool.
DaVinci_ImportMedia.jpg


3. Begin to drag and drop your files from the Media Pool onto the timeline in the order you want the files to play in. 
Once you have your final movie ready, click on the “Deliver” button and choose the Custom option and set your Custom options to:
DaVinci_Deliver.jpg


Video Settings
Render: Single Clip

1. Format: MP4
2. Codec: H.264
3. Resolution: 1280 x 720 HD 720P
4. Frame rate: 24 (Games workshops use 30fps)
DaVinci_VideoSettingsjpg.jpg

 

Audio Settings

1. Codec: AAC
2. Data Rate: 192 Kb/s
3. Bit Depth: 16
4. Output Track 1: Main 1

DaVinci_AudioSettings.jpg

 

File Settings

1. Filename uses: Custom name
2. Custom Name: Enter the name you would like for your file
3. Once your settings are entered, hit the “Add to Render Queue” and choose the location on your system for the file to render to then hit the “Start Render” button in the Render Queue.

DaVinci_FileSettings.jpg

 

IMPORTANT:

Do not use special characters when naming your file. These characters can cause conflicts or upload issues. Please limit your file names to alpha-numeric characters (a-z, A-Z, 0-9) and underscores or hyphens ( _ , -).

If you are having issues with DaVinci Resolve, you can use our old recommended program VideoPad, which you can find here:


 

Image File Instructions

As an Animation Mentor student, you should currently have a copy of GIMP or other video editing software. If you do not, you can find Animation Mentor’s software and hardware requirements here.

When submitting image files for your assignments such as renders from Maya, planning files, or other images, please ensure they follow the criteria listed below:

  1. The files are .JPG to ensure the best quality and clarity. PNG files have transparency values which may cause issues when submitted.
  2. The files have a resolution of 1280x720. With Maya renders this can easily be set for by going into Maya's Render Settings and setting the resolution of your renders.
  3. For other images such as drawings or photos, either set your digital canvas size to the required resolution, or scale your photo to match the 1280x720 resolution as closely as possible with image editing software such as GIMP.
  4. To resize an image in GIMP, open GIMP, open your image, and go to "Image > Scale Image". Enter your desired Width or Height in px (pixels), making sure scale lock is on to keep the image from distorting, then hit "Scale". Finally, save your image using "File > Save" or "File > Save As".

IMPORTANT: Do not use special characters when naming your file. These characters can cause conflicts or upload issues. Please limit your file names to alpha-numeric characters (a-z, A-Z, 0-9) and underscores or hyphens ( _ , -).


 

Common Exporting Errors and Fixes

  1. I can't import AVI files into DaVinci Resolve - If you find yourself unable to import avi files into DaVinci Resolve, we have a quick alternative program to convert avi files to mp4. The program is called MiroVideoConverter and is a simple file converter. However it does not have any video editing or advanced encoding features.

  2. Assignment drops frames after Encoding - Your file is either rendered or is not 24fps and is dropping frames during the conversion. Check your video settings to verify it is 24fps.

  3. Animatic or dialogue submissions are playing incorrectly – make sure the file is set to 24fps in the Export/Deliver settings. If the assignment file is a video reference or non-Maya playblast, it may not be 24fps by default.

  4. The assignment never fully uploads – your file size may be too large. In the export/Deliver settings, try lowering the video quality or lower the video resolution to lower the file size. Also make sure you do not have any special characters in the file name such as ( $, &, :, \, ", or ')
Was this article helpful?
3 out of 3 found this helpful
Have more questions? Submit a request Follow

Comments