Animation Mentor Support Center

Is Microsoft Edge supported?

Currently the required browsers for AnimationMentor are Google Chrome, Mozilla Firefox, and Safari. Microsoft Edge is not currently recommended and you may encounter site issues if you use it.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request Follow

Comments

Powered by Zendesk